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クライアントエラー

このページでは、WARPクライアントGUIに表示される可能性のあるエラーコードを一覧表示します。以下にエラーが表示されていない場合は、一般的な問題を参照するか、Cloudflareサポートに連絡してください。

WARP GUIのエラーメッセージの例

CF_CAPTIVE_PORTAL_TIMED_OUT

症状

  • キャプティブポータルネットワークにログインできない
  • インターネット接続なし

原因

キャプティブポータル検出がオンになっており、以下のいずれかの問題が発生しました:

  • ユーザーがWARPによって設定された時間内にキャプティブポータルのログインプロセスを完了しなかった。
  • キャプティブポータルがユーザーをまだサポートされていないフローにリダイレクトした。

解決策

  1. ユーザーがログインするための時間を増やすために、キャプティブポータルのタイムアウトを増やします。
  2. これで問題が解決しない場合は、ユーザーが手動でWARPをオフにすることを許可します。クライアントが数分後に自動的に再接続するように、自動接続の値を設定することをお勧めします。

CF_CONNECTIVITY_FAILURE_UNKNOWN

症状

  • WARPに接続できない
  • インターネット接続なし
  • ユーザーがキャプティブポータルの背後にいる可能性があります

原因

初期の接続性チェックが不明な理由で失敗しました。このエラーが発生する最も一般的な理由については、WARPに接続できないを参照してください。

解決策

  1. デバイスのWARPデバッグログを取得します。
  2. WARPに接続できないのトラブルシューティング手順に従います。

CF_DNS_LOOKUP_FAILURE

症状

  • WARPに接続できない
  • インターネットをブラウズできない
  • デバイスでnslookupおよびdigコマンドが失敗する

原因

WARPがローカルDNSプロキシを介してホスト名を解決できませんでした。

解決策

  1. ユーザーが接続しているネットワークにDNS接続があることを確認します。
  2. WARPが無効になっているときにDNS解決が機能することを確認します。
  3. DNSの制御に対してWARPに干渉しているサードパーティツールがないことを確認します。
  4. WARP IPアドレスへのトラフィックでTLS復号を実行しているサードパーティツールがないことを確認します。

CF_DNS_PROXY_FAILURE

症状

原因

サードパーティプロセス(通常はサードパーティのDNSソフトウェア)がポート53にバインドされており、これはWARPのローカルDNSプロキシがDNS解決を行うために使用します。サードパーティプロセスの名前はGUIエラーメッセージに表示されます。

macOSでは、特定のアプリケーション名の代わりにmDNSResponderが表示されることがあります。mDNSResponderは、他のプロセスの代わりにDNSリクエストを処理するmacOSのシステムプロセスです。mDNSResponderがポート53にバインドされる原因となったプロセスを特定する方法は知られていませんが、最も一般的な原因は仮想マシンソフトウェア(例:DockerやVMware Workstation)およびmacOSのインターネット共有機能です。

解決策

  1. サードパーティプロセスでDNSの干渉を削除または無効にします。

mDNSResponder

以下は、mDNSResponderがポート53にバインドされる原因となることが知られているサードパーティソフトウェアの非網羅的なリストです。mDNSResponderを停止しようとするのではなく、サードパーティソフトウェアを構成してポート53を使用しないようにするか、WARPに接続する前に一時的に無効にするべきです。

  • Docker: DockerでUDPのカーネルネットワーキングをオフにする
  • インターネット共有機能: インターネット共有を無効にするには:
    1. macOSで、システム設定 > 一般 > 共有に移動します。
    2. インターネット共有をオフにします。
  • 特定のVMソフトウェア(VMware WorkstationやParallelsなど): VMソフトウェアの存在は、問題のプログラムであることを保証するものではありません。WARPとの互換性はVMの構成に大きく依存します。この問題を回避するには、VMを実行する前にWARPに接続します:
    1. すべてのVMを停止/終了します。
    2. WARPに接続します。
    3. 再度VMを起動します。
  1. あるいは、WARPをDNSフィルタリングなしのセキュアウェブゲートウェイモードに切り替えます。

CF_FAILED_READ_SYSTEM_DNS_CONFIG

症状

  • WARPに接続できない
  • インターネットをブラウズできない

原因

WARPがシステムDNS構成を読み取れませんでした。おそらく無効なネームサーバーまたは検索ドメインが含まれています。

解決策

macOSおよびLinuxでは、/etc/resolv.conf正しくフォーマットされているかを確認し、無効な文字がないか確認します。

Windowsでは、レジストリエントリHKLM\System\CurrentControlSet\Services\TCPIP\Parameters\SearchListが有効な検索ドメインのみを含んでいることを確認します。無効なエントリの例には、IPアドレスやピリオドで始まるドメイン(例:.local)が含まれます。

CF_FAILED_TO_SET_MTLS

症状

  • WARPに接続できない

原因

デバイスがデバイス登録中に有効なmTLS証明書を提示できませんでした。

解決策

  1. 証明書のインストールに対する管理者制限がないことを確認します。
  2. デバイスにクライアント証明書を再インストールします。

CF_HAPPY_EYEBALLS_FAILURE

症状

  • WARPに接続できない

原因

ルーター、ファイアウォール、ウイルス対策ソフトウェア、または他のサードパーティのセキュリティ製品がWARPポートでUDPをブロックしています。

解決策

  1. サードパーティのセキュリティ製品を構成して、WARPのインバウンドIPとポートを許可します。
  2. インターネットルーターが正常に動作していることを確認し、ルーターを再起動してみてください。

CF_HOST_UNREACHABLE_CHECK

症状

  • WARPに接続できない
  • インターネット接続なし
  • ユーザーがキャプティブポータルの背後にいる可能性があります

原因

WARPトンネル内の接続性チェックが失敗しました。

解決策

  1. WARP IPへのトラフィックを傍受する可能性のあるサードパーティのHTTPフィルタリングソフトウェア(AV、DLP、またはファイアウォール)の存在を確認します。
  2. サードパーティソフトウェアで、WARPを通過するすべてのIPトラフィックの検査をバイパスします。WARPトンネルを通過するトラフィックを確認するには、スプリットトンネルを参照してください。

CF_INSUFFICIENT_DISK

症状

  • WARPに接続できない
  • OSがディスクがいっぱいであると警告する

原因

ハードドライブがいっぱいであるか、WARPがデータを書き込むための権限が不正です。

解決策

  1. デバイスがWARPのHDスペース要件を満たしていることを確認します。
  2. WARPがディスクスペースを使用するのを妨げる可能性のあるディスク権限を確認します。
  3. ゴミ箱を空にするか、大きなファイルを削除します。

CF_INSUFFICIENT_FILE_DESCRIPTORS

症状

  • WARPに接続できない
  • デバイス上のファイルを開けない

原因

デバイスにネットワークソケットを作成したりファイルを開いたりするのに十分なファイルディスクリプタがありません。

解決策

システム設定でファイルディスクリプタの制限を増やします。

CF_INSUFFICIENT_MEMORY

症状

  • WARPに接続できない
  • デバイスが非常に遅い

原因

デバイスにWARPを実行するのに十分なメモリがありません。

解決策

  1. デバイスがWARPの最小メモリ要件を満たしていることを確認します。
  2. 実行中のすべてのプロセスをリストしてメモリ使用量を確認します。

CF_LOCAL_POLICY_FILE_FAILED_TO_PARSE

症状

  • WARPに接続できない

原因

WARPクライアントが無効なMDM構成ファイルを使用してデバイスに展開されました。

解決策

  1. お使いのオペレーティングシステムの管理された展開ガイドを確認します。
  2. デバイス上のMDM構成ファイルを見つけます。
  3. ファイルが正しくフォーマットされており、受け入れられた引数のみを含んでいることを確認します。

CF_NO_NETWORK

症状

  • WARPに接続できない
  • インターネット接続なし

原因

デバイスがインターネットに接続されているWi-FiネットワークまたはLANに接続されていません。

解決策

  1. デバイスのネットワーク設定パネルを起動します。
  2. 有効なネットワークに接続されていることを確認します。
  3. デバイスが有効なIPアドレスを取得していることを確認します。
  4. これでエラーが解決しない場合は、デバイスを再起動するか、システムのネットワーク診断ツールを実行してみてください。

CF_REGISTRATION_MISSING

症状

  • WARPに接続できない

原因

デバイスがZero Trust組織に認証されていません。理由は以下の通りです:

  • デバイスがZero Trustで取り消された。
  • 登録が破損したか、理由不明で削除された。

解決策

  1. WARPクライアントを起動します。
  2. ギアアイコンを選択し、設定 > アカウントに移動します。
  3. セッションを再認証を選択します。
  4. 組織によって要求される認証手順を完了します。
  5. これでエラーが解決しない場合は、Cloudflare Zero Trustからログアウトを選択し、再度ログインします。ログアウトは、デバイスに対して組織を離れることを許可が有効になっている場合のみ可能です。

CF_TLS_INTERCEPTION_BLOCKING_DOH

症状

  • WARPがオンのときにDNSリクエストが解決できない。

原因

サードパーティのアプリケーションまたはサービスがWARPからのDNS over HTTPSトラフィックを傍受しています。

解決策

サードパーティのアプリケーションを構成して、WARP DoH IPを免除します。

CF_TLS_INTERCEPTION_CHECK

症状

  • WARPに接続できない

原因

デバイスまたはネットワーク上のサードパーティのセキュリティ製品がHTTPSトラフィックのTLS復号を実行しています。詳細については、トラブルシューティングガイドを参照してください。

解決策

サードパーティのセキュリティ製品で、WARP IPアドレスに対するHTTPS検査とTLS復号を無効にします。